hzcnw / TZ 文摘 / 陰線買入通達信指標公式源碼

0 0

   

陰線買入通達信指標公式源碼

2015-03-19  hzcnw
漲停:=C/REF(C,1)>1.095;
漲停10日:=COUNT(漲停,10);
漲幅:=C/REF(C,1)-1<0.05;
選股1:=漲停10日 AND 漲幅 ;
BS:=COUNT(漲停,10)<2;
M10:=MA(C,7);
M20:=MA(C,14);
M30:=MA(C,25);
VV:=M10>M20 AND M20>M30 ;
S1:=IF(NAMELIKE('S'),0,1);
S2:=IF(NAMELIKE('*'),0,1);
回踩均線:=C>MA(C,7) AND CROSS(MA(C,7),L);
S3:=DYNAINFO(17)>0;
XG:S1 AND S2 AND S3 AND 選股1 AND 回踩均線 AND VV ;
MA5:=EMA(C,5);
MA10:=EMA(C,10);
VV1:=CROSS(MA5,MA10);
VVV1:=COUNT(VV1,5)>=1;
MV5:=EMA(V,5);
MV10:=EMA(V,10);
VV2:=CROSS(MV5,MV10);
VVV2:=COUNT(VV2,5)>=1;
DIF:="MACD.DIF"(12,26,9);
DEA:="MACD.DEA"(12,26,9);
VV3:=CROSS(DIF,DEA);
VVV3:=COUNT(VV3,5)>=1;
VVV4:=ABS((C-MA10)/MA10)*100<2 AND C<REF(C,1);
漲停N:=C/REF(C,1)>=1.097;
VVV5:=COUNT(漲停N,5)>=1;
買入:VVV1 AND VVV2 AND VVV3 AND VVV4 AND VVV5;
VAR1N:CROSS(MA(C,13),C)  AND MA(C,13)>REF(MA(C,13) ,1) AND INDEXC>MA(INDEXC,13) AND  MA(C,13)>MA(C,55) AND V<REF(V,1);
VAR6B:=REF(LOW,1)*0.83;
VAR7B:=LOW*0.1;
VAR8B:=(VAR7B*VOL+VAR6B*(CAPITAL-VOL))/CAPITAL;
VAR9B:=EMA(VAR8B,60);
VARA:=EMA(VAR6B,60);
VARB:=VARA-2;
VARCB:=IF(C<=VAR9B,VARB,VARA);
VARDB:=MA(C,80)-MA(C,10)/17;
抄底:FILTER(VARCB-VARB=0 AND CROSS((EMA(EMA(EMA(C,2),2),2)-REF(EMA(EMA(EMA(C,2),2),2),1))/REF
(EMA(EMA(EMA(C,2),2),2),1)*100,MA((EMA(EMA(EMA(C,2),2),2)
-REF(EMA(EMA(EMA(C,2),2),2),1))/REF(EMA(EMA(EMA(C,2),2),2),1)*100,3)),4);
ZT:=CLOSE>REF(CLOSE,1)*1.095;
漲停后回調:REF(ZT,2) AND REF(C,1)>C AND REF(V,1)>V AND REF(C<O,1) AND C<O AND REF(C,1)<REF(C,2) AND REF(V,2)>REF(V,1),COLORYELLOW;
JJ:=(3*C+H+L+O)/6;
VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,3);
黃金線:=REF(LOW,BARSLAST(LJL));
黃金柱:=FILTER(TJ1,3);
{2.倍量過左峰}
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
倍量:=(VOL/REF(VOL,1)>2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>2);
突破前高:=CROSS(C,前高);
倍量過左峰:= 突破前高 AND 倍量;
{3.凹口起柱}
T7:=REF(VOL,6)/REF(VOL,7)>=2;
T6:=REF(VOL,5)/REF(VOL,6)>=2;
T5:=REF(VOL,5)/REF(VOL,4)>=1.5;
T4:=REF(VOL,4)/REF(VOL,3)>=1.5;
T3:=REF(VOL,2)/REF(VOL,3)>=1.5;
T1:=V/REF(VOL,1)>2;
T0:=C>O AND C>REF(C,1);
凹口起柱:= T7 AND T1 AND T0 OR T6 AND T1 AND T0 OR T5 AND T1 AND T0 OR T4 AND T1 AND T0
OR T3 AND T1 AND T0 ;
{凹口起柱}
AKQZ:= 黃金柱 AND 凹口起柱;
{4.前高低位}
X:=21;
TTY:=H;
AAT:=REF(TTY,X)=HHV(TTY,2*X+1);
BBT:=FILTER(AAT,X);
CCT:=BACKSET(BBT,X+1);
HD10T:=FILTER(CCT,X);
AA1T:=REF(TTY,X)=LLV(TTY,2*X+1);
BB1T:=FILTER(AA1T,X);
CC1T:=BACKSET(BB1T,X+1);
LD10T:=FILTER(CC1T,X);
前期高位:=REF(H,BARSLAST(HD10T));
前期低位:=REF(L,BARSLAST(LD10T));
{突破前高}
TPQG:= 黃金柱 AND 倍量過左峰 AND C>前期高位;
{選股}
XGNNB: (COUNT(TPQG,10) OR COUNT(AKQZ,10)) AND COUNT(CROSS(黃金線*1.01,L),3)>0 AND L>=黃金線 AND C>REF(C,1) AND REF(C,2)>REF(C,1) AND COUNT(LJL,3)=0;
A:=C<O;
B:=COUNT(A,4)=4;
D:=OBV-MA(OBV,30); 
E:=MA(C,20)>REF(MA(C,20),1) AND MA(C,55)>REF(MA(C,55),1);
XGB:B AND D>0 AND E;
連跌不超五天:=COUNT(DOWNNDAY(CLOSE,5),14)<1;
EMA14:=EMA(C,14);
最近放量:= (SUM(V,17)-HHV(V,17))/(SUM(V,60)-LLV(V,60))>=0.45;
創新高:=HHV(C,10)/HHV(C,144)>=0.8;
大趨勢漲:= EMA14>EMA(C,60);
小趨勢跌:= ABS(LLV(C,3)-EMA14)/EMA14<0.03;
最近放量 AND 大趨勢漲 AND 小趨勢跌  AND 創新高 AND 連跌不超五天;
N:=60;
XGNN:IF(CURRBARSCOUNT<=N,V=CONST(LLV(V,N)),DRAWNULL);
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:BB1 AND CC1 AND DD1 AND EE1;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
VARD:=EMA(IF(C< EMA(C,250),VARC*1000,VARC*10),3);
火焰山:EMA(IF(L<=LLV(L,30),VARD/2+HHV(VARD,30),0),3)/618>100;
VAR3:=1;
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARAB:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VARBB:=INTPART(VARAB*100)/100;
VARCV:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VARDV:=INTPART(VARCV*100)/100;
VAREV:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARFV:=INTPART(VAREV*100)/100;
短線趨勢:=EMA(CLOSE,5)-EMA(CLOSE,10);
中線趨勢:=EMA(短線趨勢,30);
VAR10:=-100*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR11:=-100*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR12:=-100*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR13:=-100*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR14:=REF(中線趨勢,1);
VAR15:=中線趨勢;
VAR16:=VAR15-VAR14;
VAR17:=REF(短線趨勢,1);
VAR18:=短線趨勢;
VAR19:=VAR18-VAR17;
VAR1A:=OPEN;
VAR1B:=CLOSE;
超級牛魔王:IF(VAR1A<=VAR4 AND VAR1A<=VAR5 AND VAR1A<=VAR6 AND VAR1B>=VAR4 AND VAR1B>=VARFV AND VAR16>0 AND VAR19>0 AND VAR3=1,0.5,0);
短線指標:IF(CROSS(短線趨勢,中線趨勢) AND 短線趨勢<0 AND 中線趨勢<-0.2 AND VAR11>45 AND VAR16>0 AND VAR3=1,1,0);
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*10000;
RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*10000;
短線:=SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00;
中線:=SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED;
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*10000;
長線:=SMA(RSV3,5,1),COLORYELLOW;
黃金坑:=短線<2000 AND 中線<2000 AND 長線<2000;

短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLORWHITE;
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),COLORYELLOW;
中長期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),COLORMAGENTA;
長期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLORRED,LINETHICK2;
強市線:=80,POINTDOT;
弱市線:=20,POINTDOT;
分水嶺:=50,POINTDOT;
多空:=長期<10;


NC:=5;
N1:=1;
M1:=22;
P:=19;
SJV:=C/FINANCE(34)<NC;
FZL:=FINANCE(11)/FINANCE(15)>N1;
XGC:=SJV AND FZL;


DC:=FINANCE(34)>0;
AC:=FINANCE(34);
BC:=CLOSE;
T1CC:IF(((BC/AC<3) AND DC AND 黃金坑 AND 多空 AND XGC),1,0);
NB:=10;
VAR1C:=AMOUNT/VOL/7;
VAR2C:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3C:=SUM(AMOUNT,NB)/VAR1C/7;
VAR4C:=DMA(VAR2C,VOL/VAR3C);
抄底C:=(CLOSE-VAR4C)/VAR4C*100;
CROSS(-7.0,抄底);

    本站是提供個人知識管理的網絡存儲空間,所有內容均由用戶發布,不代表本站觀點。如發現有害或侵權內容,請點擊這里 或 撥打24小時舉報電話:4000070609 與我們聯系。

    菠萝视频苹果版app

    菠萝视频苹果版app

    猜你喜歡

    0條評論

    發表

    請遵守用戶 評論公約

    類似文章
    喜歡該文的人也喜歡 更多